5 thoughts

  1. Problems with CF 8 help files for Eclipse
    I was very excited to see the extensive documentation this contains, but a lot of the links don’t work. For example: "Using the Coldfusion Debugger: Setting up Coldfusion to use the Debugger" gives the following error:
    An error occured while processing the requested document:
    org.xml.sax.SAXParseException: The element type "a" must be terminated by the matching end-tag "</a>".
    at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(Unknown Source)
    at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(Unknown Source)
    at org.eclipse.help.internal.dynamic.DocumentReader.read(DocumentReader.java:56)
    at org.eclipse.help.internal.dynamic.XMLProcessor.process(XMLProcessor.java:49)
    at org.eclipse.help.internal.xhtml.DynamicXHTMLProcessor.process(DynamicXHTMLProcessor.java:66)
    at org.eclipse.help.internal.webapp.servlet.DynamicXHTMLFilter$1.close(DynamicXHTMLFilter.java:79)
    at java.io.FilterOutputStream.close(Unknown Source)
    at org.eclipse.help.internal.webapp.servlet.FilterHTMLHeadAndBodyOutputStream.close(FilterHTMLHeadAndBodyOutputStream.java:290)
    at org.eclipse.help.internal.webapp.servlet.EclipseConnector.transfer(EclipseConnector.java:150)
    at org.eclipse.help.internal.webapp.servlet.ContentServlet.doGet(ContentServlet.java:42)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:596)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
    at org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:180)
    at org.eclipse.equinox.http.servlet.internal.ServletRegistration.handleRequest(ServletRegistration.java:90)
    at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:109)
    at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:67)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
    at org.eclipse.equinox.http.jetty.internal.HttpServerManager$InternalHttpServiceServlet.service(HttpServerManager.java:280)
    at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
    at org.mortbay.jetty.servlet.ServletHandler.dispatch(ServletHandler.java:677)
    at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
    at org.mortbay.http.HttpContext.handle(HttpContext.java:1530)
    at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)
    at org.mortbay.http.HttpServer.service(HttpServer.java:909)
    at org.mortbay.http.HttpConnection.service(HttpConnection.java:820)
    at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:986)
    at org.mortbay.http.HttpConnection.handle(HttpConnection.java:837)
    at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:245)
    at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
    at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)
    Anyone else seeing this? It’s happening on a lot of the pages for me. I’m using Eclipse 3.3, if it matters.

  2. Any reason why I’m getting no CF *function* insight in Dreamweaver CS3? Tag insight works fine. Not supported? Is there a settings option I don’t know about??

  3. I’m also finding the help files almost unusable due to the "org.xml.sax.SAXParseException" errors. It looks like the HTML isn’t proper XHTML, so the java parser isn’t able to render it…?

  4. Ben,
    I’m on Linux running Eclipse 3.2. Where do I put the JAR. ‘s I unzipped to get the extensions to work ? I currently have them in /home/myHome/.eclipse/.metadata/.plugins and that ain’t workin.
    Thanks.

  5. Sorry about the last post…. didn’t read enough before posting, been a long day…
    Anyway, I added it using the ZIP as a source, all went well but It’s not recognizing CF8 syntax. I also followed the CF8 Dictionary instructions at:
    http://www.markdrew.co.uk/blog/index.cfm/2007/6/7/CF8-Syntax-Dictionaries-for-CFEclipse
    and found the cf8.xml file was already there so I assume the above install worked. In my CFEclipse Project/Properties I still only see language up to 7.01.
    Any thoughts on what to check?
    Thanks

Leave a Reply