15 thoughts

  1. Thanks Ben! Very useful information as we start to research potential problems around here.
    BTW, why doesn’t the captcha work for me in Firefox? All I get is a black box w.’Captcha Not Available’ written inside. šŸ™

  2. Hm…I’m on my linux box and it looks fine. Must be something strange w.my ‘Portable Firefox’ I run @ work…or their horrible horrible proxy. šŸ™‚ [http://portableapps.com/apps/internet/firefox_portable]
    I’ll use IE if I ever comment again @ work. Sorry for the trouble & feel free to delete this comment. šŸ™‚

  3. One comment on the JVM update:
    In the jvm.config take note that the slashes in the path to the new JRE are FORWARD slashes and not BACK slashes. I was pasting the path in from Windows Explorer without really paying attention.

  4. Ben,
    I was under the impression that CF (7 in my case) took the sytem date from the host computer – is that not the case? If it IS the case, do we still need to install the new JVM? If I am wrong in my assumption, is it possible to set the date/time for one CF instance to be differen to the others? (I only ask because this would be good for testing).
    For the record, we are set up with the multi-server install.
    Cheers,
    David

  5. Hmmm.
    I downloaded the new "j2sdk1.4.2_11" and unpacked it to the "C:Program FilesJava" on the server. Modified the "jvm.config" file to read:
    java.home=C:/Program Files/Java/j2sdk1.4.2_11
    After I restart the services I see in the CF admin that it is still using the
    Java Home: C:Program FilesJavaj2re1.4.2_08
    Did I miss a step? Does the whole server need to rebooted?
    Thanks for any help.

  6. Disregard. I’m a slow this morning. Multiserver configuration. Looking in the incorrect "jvm.config" file.
    Thanks anyway!

  7. Win OS DST 2007 patch may require full OS reboot in some cases.
    We run CF "7,0,2,142559" on Sun’s JVM "1.5.0-b64", and on our Feb 28 JVM restart (just service, not OS) some of our production servers reported that ColdFusion was off by 5 hours. Presumably the source was the Sun JVM, and being we are EST we believe it reverted to GMT.
    The hosting group reported that they had applied the Windows DST 2007 patches (http://support.microsoft.com/kb/931836/) to all these machines, sometime between last JVM restart and the current restart.
    In our case a full OS reboot of the problematic web servers solved our time issue. The only difference we could find was that the problem servers had been up 48 days, while the others had been OS rebooted recently. Presumably, the Win OS DST patches were applied without OS reboot, and the JVM restart did not sync well without full Win OS reboot.
    On a side note, "1.5.0-b64" is not patched for DST March 11 as noted at "http://java.sun.com/developer/technicalArticles/Intl/USDST_Faq.html", since "1.5.0xxx" is the same as "5.0xxx", and we need "u6" (update 6) not an earlier beta.

  8. something I can’t tell from the CF5 workaround: should we always be subtracting an hour before using dateconvert() or is it only during the extra week before and after the previous DST timeframe?

  9. nevermind, found a better explaination of the TechNote at Sarge’s Blog:
    "UTC conversions will be off by an hour during the new DST periods –i.e. from March 11 (new DST start) – April 1 (old DST start)"

  10. I’m running 1.4.2_11-b06 but the time is still one hour ahead. I also ran the tzupdater tool, just in case. Also, CFMX has been restarted. What could be the problem?

Leave a Reply to Alexander Cancel reply